import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w_]+).*?([\\w_]+)\\(\\+\\)";
final String string = "a.deptno = b.dept_no(+)\n"
+ "c.deptno(+)=b.dept_no\n"
+ "a.deptno(+)= 900\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}