const regex = new RegExp('([\\w_]+).*?([\\w_]+)\\(\\+\\)', 'g')
const str = `a.deptno = b.dept_no(+)
c.deptno(+)=b.dept_no
a.deptno(+)= 900
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}