#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?=query|mutation).+?(?=query|mutation|\Z)"
Local $sString = "query get_telemetry (name: String, start_time: String, end_time: String) {" & @CRLF & _
" parameters:satelliteOperatorInteractionParameters(name: $name) {" & @CRLF & _
" edges {" & @CRLF & _
" node {" & @CRLF & _
" name" & @CRLF & _
" path" & @CRLF & _
" states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {" & @CRLF & _
" edges {" & @CRLF & _
" node {" & @CRLF & _
" timestamp" & @CRLF & _
" calibrated_value:calibratedValue" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"mutation get_all_possible_parameters {" & @CRLF & _
" parameters:satelliteOperatorInteractionParameters {" & @CRLF & _
" edges {" & @CRLF & _
" node {" & @CRLF & _
" path" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")