import re
regex = re.compile(r"(?=query|mutation).+?(?=query|mutation|\Z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("query get_telemetry (name: String, start_time: String, end_time: String) {\n"
" parameters:satelliteOperatorInteractionParameters(name: $name) {\n"
" edges {\n"
" node {\n"
" name\n"
" path\n"
" states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {\n"
" edges {\n"
" node {\n"
" timestamp\n"
" calibrated_value:calibratedValue\n"
" }\n"
" }\n"
" }\n"
" }\n"
" }\n"
" }\n"
"}\n\n"
"mutation get_all_possible_parameters {\n"
" parameters:satelliteOperatorInteractionParameters {\n"
" edges {\n"
" node {\n"
" path\n"
" }\n"
" }\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")