using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=\s))national(?=\s|$)";
string input = @"national fajfjlajllfsjakljf fj alkfjklajf jafl fjlajl
international
jfalkj jalkfjda national
inter-national
international
inter_national";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}