re = /(?:^|(?<=\s))national(?=\s|$)/m
str = 'national fajfjlajllfsjakljf fj alkfjklajf jafl fjlajl
international
jfalkj jalkfjda national
inter-national
international
inter_national'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end