# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?=.*(?:пишет:|обращается:))//gm;t' <<< "elasez uyefot 2 пишет: а вот когда пишу я то нет"