use strict;
my $str = 'elasez uyefot 2 пишет: а вот когда пишу я то нет';
my $regex = qr/\d+(?=.*(?:пишет:|обращается:))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";