$re = '/\d+(?=.*(?:пишет:|обращается:))/m';
$str = 'elasez uyefot 2 пишет: а вот когда пишу я то нет';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;