# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9]*(?=\-)/X/g;t' <<< "1234-123-1234
2234-22-1234
32-32-1234"