const regex = /[0-9]*(?=\-)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]*(?=\\-)', 'g')
const str = `1234-123-1234
2234-22-1234
32-32-1234`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);