$re = '/[0-9]*(?=\-)/';
$str = '1234-123-1234
2234-22-1234
32-32-1234';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;