using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^this is a (""|)([^""\s]+)(\1)\s*$";
string input = @"this is a ""xyz""";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}