const regex = /^this is a ("|)([^"\s]+)(\1)\s*$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^this is a ("|)([^"\\s]+)(\\1)\\s*$', 's')
const str = `this is a "xyz"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}