package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\bl\b|\bL\b)`)
var str = `Look at the l in this message even with caps L but not inside wordLhere orlthis. lemon Lemon `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}