$re = '/(\bl\b|\bL\b)/';
$str = 'Look at the l in this message even with caps L but not inside wordLhere orlthis. lemon Lemon ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);