re = /(\bl\b|\bL\b)/
str = 'Look at the l in this message even with caps L but not inside wordLhere orlthis. lemon Lemon '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end