re = /\\(\w)*\\/m
str = 'D:\\pcap\\WebMail
D:\\pcap1\\WebMail\\1\\1
C:\\pcap\\WebMail\\sd\\
D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml'
subst = '\\\\replacedFolder\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result