using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\()(?:[^()]+|\([^)]+\))+";
string input = @"[adapter_name='EDSON TURISMO GPASS', key='1', name='sao jose dos campos', state='SP']";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}