re = /(?<=\()(?:[^()]+|\([^)]+\))+/
str = '[adapter_name=\'EDSON TURISMO GPASS\', key=\'1\', name=\'sao jose dos campos\', state=\'SP\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end