$re = '/(?<=\()(?:[^()]+|\([^)]+\))+/';
$str = '[adapter_name=\'EDSON TURISMO GPASS\', key=\'1\', name=\'sao jose dos campos\', state=\'SP\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);