using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<arg> # Start arg group
(?<key>\w+) # key group: 1+ word chars
= # =
(?<quote>['""`]?) # quote group: an optional "" ' or `
(?<value>(?:(?!\k<quote>)[^\\])*(?:\\[\s\S](?:(?!\k<quote>)[^\\])*)*) # value group: any 0+ chars other than quote char with escaped quote chars allowed
\k<quote> # quote group value
) # end of arg group";
string input = @"arg=""value"" arg='value' arg=`value` arg=""value 'value'"" arg='value \'value\' value' arg=""value \""value\"" value"" arg=`value \`value\ value`";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}