import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<arg> # Start arg group\n"
+ " (?<key>\\w+) # key group: 1+ word chars\n"
+ " = # =\n"
+ " (?<quote>['\"`]?) # quote group: an optional \" ' or `\n"
+ " (?<value>(?:(?!\\k<quote>)[^\\\\])*(?:\\\\[\\s\\S](?:(?!\\k<quote>)[^\\\\])*)*) # value group: any 0+ chars other than quote char with escaped quote chars allowed\n"
+ " \\k<quote> # quote group value\n"
+ ") # end of arg group";
final String string = "arg=\"value\" arg='value' arg=`value` arg=\"value 'value'\" arg='value \\'value\\' value' arg=\"value \\\"value\\\" value\" arg=`value \\`value\\ value`";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}