package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<arg> # Start arg group
(?<key>\w+) # key group: 1+ word chars
= # =
(?<quote>['"`]?) # quote group: an optional " ' or `
(?<value>(?:(?!\k<quote>)[^\\])*(?:\\[\s\S](?:(?!\k<quote>)[^\\])*)*) # value group: any 0+ chars other than quote char with escaped quote chars allowed
\k<quote> # quote group value
) # end of arg group`)
var str = `arg="value" arg='value' arg=\`value\` arg="value 'value'" arg='value \'value\' value' arg="value \"value\" value" arg=\`value \\`value\ value\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}