const regex = /(?<=Due Date )\d{2}.[A-Z]{3}.\d{4}|(?<=Terms )(\S.+)|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4})|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)|(?<=\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4}.)|(?<=\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Due Date )\\d{2}.[A-Z]{3}.\\d{4}|(?<=Terms )(\\S.+)|(?<=Terms\\n\\n\\d{2}.[A-Z]{3}.\\d{4}.)(\\d{2}.[A-Z]{3}.\\d{4})|(?<=Terms\\n\\n\\d{2}.[A-Z]{3}.\\d{4}.\\d{2}.[A-Z]{3}.\\d{4}.)(\\S.+)|(?<=\\d{2}.[A-Z]{3}.\\d{4}.)(\\d{2}.[A-Z]{3}.\\d{4}.)|(?<=\\d{2}.[A-Z]{3}.\\d{4}.\\d{2}.[A-Z]{3}.\\d{4}.)(\\S.+)', 'g')
const str = `Invoice Number Invoice Date Due Date Terms
Remit To 100 USD Remit To 200
XI 3849 30 MAR 2017 29 APR 2017 Within 30 days Due net
Sample 2)
Due Date 30 SEP 2017
Terms Within 30 days Due net
Sample 3)
Invoice Date Due Date Terms
30 MAR 2018 29 APR 2018 Not more than 30 days`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}