import Foundation
let pattern = #"(?<=Due Date )\d{2}.[A-Z]{3}.\d{4}|(?<=Terms )(\S.+)|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4})|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)|(?<=\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4}.)|(?<=\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Invoice Number Invoice Date Due Date Terms
Remit To 100 USD Remit To 200
XI 3849 30 MAR 2017 29 APR 2017 Within 30 days Due net
Sample 2)
Due Date 30 SEP 2017
Terms Within 30 days Due net
Sample 3)
Invoice Date Due Date Terms
30 MAR 2018 29 APR 2018 Not more than 30 days
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)