$re = '/(?<=Due Date )\d{2}.[A-Z]{3}.\d{4}|(?<=Terms )(\S.+)|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4})|(?<=Terms\n\n\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)|(?<=\d{2}.[A-Z]{3}.\d{4}.)(\d{2}.[A-Z]{3}.\d{4}.)|(?<=\d{2}.[A-Z]{3}.\d{4}.\d{2}.[A-Z]{3}.\d{4}.)(\S.+)/';
$str = 'Invoice Number Invoice Date Due Date Terms
Remit To 100 USD Remit To 200
XI 3849 30 MAR 2017 29 APR 2017 Within 30 days Due net
Sample 2)
Due Date 30 SEP 2017
Terms Within 30 days Due net
Sample 3)
Invoice Date Due Date Terms
30 MAR 2018 29 APR 2018 Not more than 30 days';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);