using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\S{1,3}\b";
string input = @"mother dog TWO мамой мАм 1А2 маМ 123 мам Мама ма М м 1 1м более трёх символов";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}