// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\S{1,3}\b").unwrap();
let string = "mother dog TWO мамой мАм 1А2 маМ 123 мам Мама ма М м 1 1м более трёх символов";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}