$re = '/\b\S{1,3}\b/m';
$str = 'mother dog TWO мамой мАм 1А2 маМ 123 мам Мама ма М м 1 1м более трёх символов';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);