using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=(""|')https?:\/\/(*SKIP)(*FAIL)|href=(""|')(.*?)\2";
string input = @"<a href=""http://website.com/"" />
<a href=""/link1"" />
<a href=""https://website.com"" />
<a href=""link1"" />";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}