$re = '/href=("|\')https?:\/\/(*SKIP)(*FAIL)|href=("|\')(.*?)\2/i';
$str = '<a href="http://website.com/" />
<a href="/link1" />
<a href="https://website.com" />
<a href="link1" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);