re = /href=("|')https?:\/\/(*SKIP)(*FAIL)|href=("|')(.*?)\2/i
str = '<a href="http://website.com/" />
<a href="/link1" />
<a href="https://website.com" />
<a href="link1" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end