#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[:=]\s*([\w\s]*)"
Local $sString = "SOMETEXT: ANYTHING_HERE (Old=ANYTHING_HERE, New=ANYTHING_HERE)" & @CRLF & _
"ABC: Some_Field (Old=,New=123)" & @CRLF & _
"ABC: Some_Field (Old=ABCde,New=1234)" & @CRLF & _
"ABC: Some_Field (Old=Hello World,New=Bye Bye World)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")