package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[:=]\s*([\w\s]*)`)
var str = `SOMETEXT: ANYTHING_HERE (Old=ANYTHING_HERE, New=ANYTHING_HERE)
ABC: Some_Field (Old=,New=123)
ABC: Some_Field (Old=ABCde,New=1234)
ABC: Some_Field (Old=Hello World,New=Bye Bye World)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}