import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[:=]\\s*([\\w\\s]*)";
final String string = "SOMETEXT: ANYTHING_HERE (Old=ANYTHING_HERE, New=ANYTHING_HERE)\n"
+ "ABC: Some_Field (Old=,New=123)\n"
+ "ABC: Some_Field (Old=ABCde,New=1234)\n"
+ "ABC: Some_Field (Old=Hello World,New=Bye Bye World)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}