$re = '/(?<=[^\(\s])(?=\()|(?<=\))(?=[^\)\s])/';
$str = 'text1(text2)(text2)ddddd';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;