re = /(?<=[^\(\s])(?=\()|(?<=\))(?=[^\)\s])/
str = 'text1(text2)(text2)ddddd'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result