import re
regex = re.compile(r"(?<=[^\(\s])(?=\()|(?<=\))(?=[^\)\s])")
test_str = "text1(text2)(text2)ddddd"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)