using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B,\B";
string input = @"(y3,x3),(r4,t4),(y3,x3),(r4,t4),(y3,x3),(r4,t4)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}