$re = '/\B,\B/';
$str = '(y3,x3),(r4,t4),(y3,x3),(r4,t4),(y3,x3),(r4,t4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);