package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B,\B`)
var str = `(y3,x3),(r4,t4),(y3,x3),(r4,t4),(y3,x3),(r4,t4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}