# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0(?!F*~)|([0-F])(?=F*~[0-F]*?\1([0-F]))|~[0-F]*/$2/g;t' <<< "09~0123456789ABCDEF0"