re = /\b0(?!F*~)|([0-F])(?=F*~[0-F]*?\1([0-F]))|~[0-F]*/
str = '09~0123456789ABCDEF0'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result