const regex = /\b0(?!F*~)|([0-F])(?=F*~[0-F]*?\1([0-F]))|~[0-F]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0(?!F*~)|([0-F])(?=F*~[0-F]*?\\1([0-F]))|~[0-F]*', 'g')
const str = `09~0123456789ABCDEF0`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);