using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:ne?t\s(?:profit|earning)\s)([\d\.]+\s(?:million|laks|crore))";
string input = @"business venture of net profit 23.5 million dollars";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}