package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:ne?t\s(?:profit|earning)\s)([\d\.]+\s(?:million|laks|crore))`)
var str = `business venture of net profit 23.5 million dollars`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}