$re = '/(?:ne?t\s(?:profit|earning)\s)([\d\.]+\s(?:million|laks|crore))/';
$str = 'business venture of net profit 23.5 million dollars';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);