# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div(?!>).*?class="myClass".*?>(.*?)<\\/div>/$1/gmi;t' <<< "<div class=\"test\"></div><div></div><div id=\"foo\" class=\"myClass\" title=\"bar\">Works</div>"