$re = '/<div(?!>).*?class="myClass".*?>(.*?)<\/div>/mi';
$str = '<div class="test"></div><div></div><div id="foo" class="myClass" title="bar">Works</div>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;